re = /^(?:git|ssh|https?|git@[-\w.]+):(\/\/)?(.*?)(\.git)(\/?|\#[-\d\w._]+?)$/m
str = 'git@bitbucket.org:blackswan-avionics/pac-ppe-portal-phase3.git'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result