use strict;
my $str = 'git@bitbucket.org:blackswan-avionics/pac-ppe-portal-phase3.git';
my $regex = qr/^(?:git|ssh|https?|git@[-\w.]+):(\/\/)?(.*?)(\.git)(\/?|\#[-\d\w._]+?)$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";