const regex = /^(?:git|ssh|https?|git@[-\w.]+):(\/\/)?(.*?)(\.git)(\/?|\#[-\d\w._]+?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:git|ssh|https?|git@[-\\w.]+):(\\\/\\\/)?(.*?)(\\.git)(\\\/?|\\#[-\\d\\w._]+?)$', 'gm')
const str = `git@bitbucket.org:blackswan-avionics/pac-ppe-portal-phase3.git`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);