package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:git|ssh|https?|git@[-\w.]+):(\/\/)?(.*?)(\.git)(\/?|\#[-\d\w._]+?)$`)
var str = `git@bitbucket.org:blackswan-avionics/pac-ppe-portal-phase3.git`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}