re = /^(.+)(\@)(\w+)(\.)(\w{3,4})$/m
str = 'some@email.com
yo@email.com
yoo@email.com
212@yahoo.com
@yahoo.com
moreover@.
superb@.com
yahoo.com@superninja.net
hmmer.com@
some@email.body
superb@new.horizon
super.man.followme@neworld.wow'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end