import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.+)(\\@)(\\w+)(\\.)(\\w{3,4})$";
final String string = "some@email.com\n"
+ "yo@email.com\n"
+ "yoo@email.com\n"
+ "212@yahoo.com\n"
+ "@yahoo.com\n"
+ "moreover@.\n"
+ "superb@.com\n"
+ "yahoo.com@superninja.net\n"
+ "hmmer.com@\n"
+ "some@email.body\n"
+ "superb@new.horizon\n"
+ "super.man.followme@neworld.wow";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}