package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.+)(\@)(\w+)(\.)(\w{3,4})$`)
var str = `some@email.com
yo@email.com
yoo@email.com
212@yahoo.com
@yahoo.com
moreover@.
superb@.com
yahoo.com@superninja.net
hmmer.com@
some@email.body
superb@new.horizon
super.man.followme@neworld.wow`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}