using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.+)(\@)(\w+)(\.)(\w{3,4})$";
string input = @"some@email.com
yo@email.com
yoo@email.com
212@yahoo.com
@yahoo.com
moreover@.
superb@.com
yahoo.com@superninja.net
hmmer.com@
some@email.body
superb@new.horizon
super.man.followme@neworld.wow";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}