const regex = /^(?<scheme>[a-z]+:\/\/)(?:(?<username>[^\/:@]+)(?::(?<password>[^\/:@]+))?@)?(?<host>[^\/]+)(?:(?<path>\/[^?#]+)(?:(?<query>[^#]+)?)?(?:#(?<fragment>.*))?)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<scheme>[a-z]+:\\\/\\\/)(?:(?<username>[^\\\/:@]+)(?::(?<password>[^\\\/:@]+))?@)?(?<host>[^\\\/]+)(?:(?<path>\\\/[^?#]+)(?:(?<query>[^#]+)?)?(?:#(?<fragment>.*))?)?', 'gm')
const str = `http://foxcat:hunter2@ftp.example.com/a/funny/path/to/@v3.0.0.tar.gz?t=1394939395#why-is-there-a-fragment-here
https://github.com∕kubernetes∕kubernetes∕archive∕refs∕tags∕@v1271.zip`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}