using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<scheme>[a-z]+:\/\/)(?:(?<username>[^\/:@]+)(?::(?<password>[^\/:@]+))?@)?(?<host>[^\/]+)(?:(?<path>\/[^?#]+)(?:(?<query>[^#]+)?)?(?:#(?<fragment>.*))?)?";
string input = @"http://foxcat:hunter2@ftp.example.com/a/funny/path/to/@v3.0.0.tar.gz?t=1394939395#why-is-there-a-fragment-here
https://github.com∕kubernetes∕kubernetes∕archive∕refs∕tags∕@v1271.zip";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}