import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<scheme>[a-z]+:\\/\\/)(?:(?<username>[^\\/:@]+)(?::(?<password>[^\\/:@]+))?@)?(?<host>[^\\/]+)(?:(?<path>\\/[^?#]+)(?:(?<query>[^#]+)?)?(?:#(?<fragment>.*))?)?";
final String string = "http://foxcat:hunter2@ftp.example.com/a/funny/path/to/@v3.0.0.tar.gz?t=1394939395#why-is-there-a-fragment-here\n"
+ "https://github.com∕kubernetes∕kubernetes∕archive∕refs∕tags∕@v1271.zip";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}