import Foundation
let pattern = ##"(?<=(?:[?&]))foo(?:=([^&#]+))?\b"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"?foo=foo&foo=bar&foo&nonfoo=bar&nonfoo&foo#foo=bar"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"foo=..."#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)