#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<=(?:[?&]))foo(?:=([^&#]+))?\b"
Local $sString = "?foo=foo&foo=bar&foo&nonfoo=bar&nonfoo&foo#foo=bar"
Local $sSubst = "foo=..."
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)