$re = '/(?<=(?:[?&]))foo(?:=([^&#]+))?\b/';
$str = '?foo=foo&foo=bar&foo&nonfoo=bar&nonfoo&foo#foo=bar';
$subst = "foo=...";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;