use strict;
my $str = '?foo=foo&foo=bar&foo&nonfoo=bar&nonfoo&foo#foo=bar';
my $regex = qr/(?<=(?:[?&]))foo(?:=([^&#]+))?\b/p;
my $subst = 'foo=...';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";