// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)^[^\p{L}:]|.[^\p{L}0-9:\-_]|[^\p{L}0-9]$").unwrap();
let string = "wdadù
-wdadw
_wdwdawd
23
_33454
.2435
now how
dww
test-now
àwdàawd
wad-àùùdw
test_ok";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}