# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[^\p{L}:]|.[^\p{L}0-9:\-_]|[^\p{L}0-9]$"
test_str = ("wdadù\n"
"-wdadw\n"
"_wdwdawd\n"
"23\n"
"_33454\n"
".2435\n"
"now how\n"
"dww\n"
"test-now\n"
"àwdàawd\n"
"wad-àùùdw\n"
"test_ok")
matches = re.search(regex, test_str, re.UNICODE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.