#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)^[^\p{L}:]|.[^\p{L}0-9:\-_]|[^\p{L}0-9]$"
Local $sString = "wdadù" & @CRLF & _
"-wdadw" & @CRLF & _
"_wdwdawd" & @CRLF & _
"23" & @CRLF & _
"_33454" & @CRLF & _
".2435" & @CRLF & _
"now how" & @CRLF & _
"dww" & @CRLF & _
"test-now" & @CRLF & _
"àwdàawd" & @CRLF & _
"wad-àùùdw" & @CRLF & _
"test_ok"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")