re = /^[^\p{L}:]|.[^\p{L}0-9:\-_]|[^\p{L}0-9]$/
str = 'wdadù
-wdadw
_wdwdawd
23
_33454
.2435
now how
dww
test-now
àwdàawd
wad-àùùdw
test_ok'
# Print the match result
str.match(re) do |match|
puts match.to_s
end