import Foundation
let pattern = #"\{\s*?(?=[a-z0-9-]*[A-Z])(.+)\.(?:i|I)*\s*?\}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
FIND {N-CODREM.i} wher
FIND {N-CODRE99.i} wher
FIND { N-CODREM.i } wher
FIND { N-CODREM.I } wher
e {n-codrem.i}.motcle = "VTE"
e {n-codre99.i}.motcle = "VTE""
e {n-coDRe99.i}.motcle = "VTE"
e {n-coDRem.i}.motcle = "VTE"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)