import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\s*?(?=[a-z0-9-]*[A-Z])(.+)\\.(?:i|I)*\\s*?\\}";
final String string = " FIND {N-CODREM.i} wher\n"
+ " FIND {N-CODRE99.i} wher\n"
+ " FIND { N-CODREM.i } wher\n"
+ " FIND { N-CODREM.I } wher\n"
+ "e {n-codrem.i}.motcle = \"VTE\"\n"
+ "e {n-codre99.i}.motcle = \"VTE\"\"\n"
+ "e {n-coDRe99.i}.motcle = \"VTE\"\n"
+ "e {n-coDRem.i}.motcle = \"VTE\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}