const regex = /\{\s*?(?=[a-z0-9-]*[A-Z])(.+)\.(?:i|I)*\s*?\}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{\\s*?(?=[a-z0-9-]*[A-Z])(.+)\\.(?:i|I)*\\s*?\\}', 'g')
const str = ` FIND {N-CODREM.i} wher
FIND {N-CODRE99.i} wher
FIND { N-CODREM.i } wher
FIND { N-CODREM.I } wher
e {n-codrem.i}.motcle = "VTE"
e {n-codre99.i}.motcle = "VTE""
e {n-coDRe99.i}.motcle = "VTE"
e {n-coDRem.i}.motcle = "VTE"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}