$re = '/\{\s*?(?=[a-z0-9-]*[A-Z])(.+)\.(?:i|I)*\s*?\}/';
$str = ' FIND {N-CODREM.i} wher
FIND {N-CODRE99.i} wher
FIND { N-CODREM.i } wher
FIND { N-CODREM.I } wher
e {n-codrem.i}.motcle = "VTE"
e {n-codre99.i}.motcle = "VTE""
e {n-coDRe99.i}.motcle = "VTE"
e {n-coDRem.i}.motcle = "VTE"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);