$re = '/\s.*,/';
$str = 'Jose Jose Ricardo, lopez de montana.';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;