use strict;
my $str = 'Jose Jose Ricardo, lopez de montana.';
my $regex = qr/\s.*,/p;
my $subst = ',';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";