$re = '/customer name is ([\w\s]*?(?=(?:and|or|$)))?(?:(?:(?:and|or) customer id is )(\d*)|c)? ?(?:(?:(?:and|or) policy id is ([a-zA-Z0-9]*)))?/m';
$str = 'customer name is jason estibeiro and customer id is 1234532
customer name is jason estibeiro or customer id is 1234532
customer name is sajal sharma and customer id is 1234532 and policy id is abcd1234
customer name is sajal sharma and customer id is 1234532 or policy id is abcd1234
customer name is sajal sharma or customer id is 1234532 and policy id is abcd1234
customer name is sajal sharma or customer id is 1234532 or policy id is abcd1234
customer name is tarun and policy id is abcd1234
customer name is tarun or policy id is abcd1234
customer name is omkar
customer name is dhiraj nambiar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);