#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)customer name is ([\w\s]*?(?=(?:and|or|$)))?(?:(?:(?:and|or) customer id is )(\d*)|c)? ?(?:(?:(?:and|or) policy id is ([a-zA-Z0-9]*)))?"
Local $sString = "customer name is jason estibeiro and customer id is 1234532" & @CRLF & _
"customer name is jason estibeiro or customer id is 1234532" & @CRLF & _
"customer name is sajal sharma and customer id is 1234532 and policy id is abcd1234" & @CRLF & _
"customer name is sajal sharma and customer id is 1234532 or policy id is abcd1234" & @CRLF & _
"customer name is sajal sharma or customer id is 1234532 and policy id is abcd1234" & @CRLF & _
"customer name is sajal sharma or customer id is 1234532 or policy id is abcd1234" & @CRLF & _
"customer name is tarun and policy id is abcd1234" & @CRLF & _
"customer name is tarun or policy id is abcd1234" & @CRLF & _
"customer name is omkar" & @CRLF & _
"customer name is dhiraj nambiar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")