use strict;
my $str = 'customer name is jason estibeiro and customer id is 1234532
customer name is jason estibeiro or customer id is 1234532
customer name is sajal sharma and customer id is 1234532 and policy id is abcd1234
customer name is sajal sharma and customer id is 1234532 or policy id is abcd1234
customer name is sajal sharma or customer id is 1234532 and policy id is abcd1234
customer name is sajal sharma or customer id is 1234532 or policy id is abcd1234
customer name is tarun and policy id is abcd1234
customer name is tarun or policy id is abcd1234
customer name is omkar
customer name is dhiraj nambiar';
my $regex = qr/customer name is ([\w\s]*?(?=(?:and|or|$)))?(?:(?:(?:and|or) customer id is )(\d*)|c)? ?(?:(?:(?:and|or) policy id is ([a-zA-Z0-9]*)))?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}