const regex = /customer name is ([\w\s]*?(?=(?:and|or|$)))?(?:(?:(?:and|or) customer id is )(\d*)|c)? ?(?:(?:(?:and|or) policy id is ([a-zA-Z0-9]*)))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('customer name is ([\\w\\s]*?(?=(?:and|or|$)))?(?:(?:(?:and|or) customer id is )(\\d*)|c)? ?(?:(?:(?:and|or) policy id is ([a-zA-Z0-9]*)))?', 'gm')
const str = `customer name is jason estibeiro and customer id is 1234532
customer name is jason estibeiro or customer id is 1234532
customer name is sajal sharma and customer id is 1234532 and policy id is abcd1234
customer name is sajal sharma and customer id is 1234532 or policy id is abcd1234
customer name is sajal sharma or customer id is 1234532 and policy id is abcd1234
customer name is sajal sharma or customer id is 1234532 or policy id is abcd1234
customer name is tarun and policy id is abcd1234
customer name is tarun or policy id is abcd1234
customer name is omkar
customer name is dhiraj nambiar`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}