// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<style>[\x00-\xFF]+<\/style>").unwrap();
let string = "
<style>
html, body {
position: absolute;
margin: 0;
padding: 0;
width: 100%;
height: 100%;
}
</style>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}