$re = '/<style>[\x00-\xFF]+<\/style>/m';
$str = '
<style>
html, body {
position: absolute;
margin: 0;
padding: 0;
width: 100%;
height: 100%;
}
</style>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);