import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<style>[\\x00-\\xFF]+<\\/style>";
final String string = "\n"
+ " <style>\n"
+ " html, body {\n"
+ " position: absolute;\n"
+ " margin: 0;\n"
+ " padding: 0;\n"
+ " width: 100%;\n"
+ " height: 100%;\n"
+ " }\n"
+ " </style>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}