const regex = /<style>[\x00-\xFF]+<\/style>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<style>[\\x00-\\xFF]+<\\\/style>', 'gm')
const str = `
<style>
html, body {
position: absolute;
margin: 0;
padding: 0;
width: 100%;
height: 100%;
}
</style>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}