import Foundation
let pattern = #"(<a.*?(?:href=")?)?(https?:\/\/)?(?:www\.)?(?:youtu\.be\/|youtube\.com(?:\/embed\/|\/v\/|\/watch?.*?v=))([\w\-]{10,12})(.*<\/a>?)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"""
<p> </p>
<p> </p>
https://www.youtube.com/watch?v=yCrjqNJgkNA
<p> </p>
<p> </p>
www.youtube.com/watch?v=TkRYM3Vt5v4
<p> </p>
<p> </p>
<p> </p>
http://www.youtube.com/watch?v=nfPYWD3Hxd4
<p><a href="https://www.youtube.com/watch?v=xV-ny2fNauA">https://www.youtube.com/watch?v=xV-ny2fNauA</a></p>
<p><a href="https://www.youtube.com/watch?v=4Quu-22CqHg">https://www.youtube.com/watch?v=4Quu-22CqHg</a></p>
<p><a href="https://www.youtube.com/watch?v=5BlLmJxNV0s">https://www.youtube.com/watch?v=5BlLmJxNV0s</a></p>
<p><a href="https://www.youtube.com/watch?v=wtMoYjUIpDk">https://www.youtube.com/watch?v=wtMoYjUIpDk</a></p>
<p><a href="https://www.youtube.com/watch?v=9U35vNlwj3o">https://www.youtube.com/watch?v=9U35vNlwj3o</a></p>
<p><a href="https://www.youtube.com/watch?v=lFITZBBz_lk">https://www.youtube.com/watch?v=lFITZBBz_lk</a></p>
<p><a href="https://www.youtube.com/watch?v=jjIp1qSkfgg">https://www.youtube.com/watch?v=jjIp1qSkfgg</a></p>
<p><a href="https://www.youtube.com/watch?v=KM5g6wpY8a4">https://www.youtube.com/watch?v=KM5g6wpY8a4</a></p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)