import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<a.*?(?:href=\")?)?(https?:\\/\\/)?(?:www\\.)?(?:youtu\\.be\\/|youtube\\.com(?:\\/embed\\/|\\/v\\/|\\/watch?.*?v=))([\\w\\-]{10,12})(.*<\\/a>?)?";
final String string = "<p> </p>\n"
+ "<p> </p>\n"
+ "https://www.youtube.com/watch?v=yCrjqNJgkNA\n"
+ "<p> </p>\n"
+ "<p> </p>\n"
+ "www.youtube.com/watch?v=TkRYM3Vt5v4\n"
+ "<p> </p>\n"
+ "<p> </p>\n"
+ "<p> </p>\n"
+ "http://www.youtube.com/watch?v=nfPYWD3Hxd4\n"
+ "<p><a href=\"https://www.youtube.com/watch?v=xV-ny2fNauA\">https://www.youtube.com/watch?v=xV-ny2fNauA</a></p>\n"
+ "<p><a href=\"https://www.youtube.com/watch?v=4Quu-22CqHg\">https://www.youtube.com/watch?v=4Quu-22CqHg</a></p>\n"
+ "<p><a href=\"https://www.youtube.com/watch?v=5BlLmJxNV0s\">https://www.youtube.com/watch?v=5BlLmJxNV0s</a></p>\n"
+ "<p><a href=\"https://www.youtube.com/watch?v=wtMoYjUIpDk\">https://www.youtube.com/watch?v=wtMoYjUIpDk</a></p>\n"
+ "<p><a href=\"https://www.youtube.com/watch?v=9U35vNlwj3o\">https://www.youtube.com/watch?v=9U35vNlwj3o</a></p>\n"
+ "<p><a href=\"https://www.youtube.com/watch?v=lFITZBBz_lk\">https://www.youtube.com/watch?v=lFITZBBz_lk</a></p>\n"
+ "<p><a href=\"https://www.youtube.com/watch?v=jjIp1qSkfgg\">https://www.youtube.com/watch?v=jjIp1qSkfgg</a></p>\n"
+ "<p><a href=\"https://www.youtube.com/watch?v=KM5g6wpY8a4\">https://www.youtube.com/watch?v=KM5g6wpY8a4</a></p>";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}