# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(<a.*?(?:href=")?)?(https?:\/\/)?(?:www\.)?(?:youtu\.be\/|youtube\.com(?:\/embed\/|\/v\/|\/watch?.*?v=))([\w\-]{10,12})(.*<\/a>?)?
"""
test_str = ("<p> </p>\n"
"<p> </p>\n"
"https://www.youtube.com/watch?v=yCrjqNJgkNA\n"
"<p> </p>\n"
"<p> </p>\n"
"www.youtube.com/watch?v=TkRYM3Vt5v4\n"
"<p> </p>\n"
"<p> </p>\n"
"<p> </p>\n"
"http://www.youtube.com/watch?v=nfPYWD3Hxd4\n"
"<p><a href=\"https://www.youtube.com/watch?v=xV-ny2fNauA\">https://www.youtube.com/watch?v=xV-ny2fNauA</a></p>\n"
"<p><a href=\"https://www.youtube.com/watch?v=4Quu-22CqHg\">https://www.youtube.com/watch?v=4Quu-22CqHg</a></p>\n"
"<p><a href=\"https://www.youtube.com/watch?v=5BlLmJxNV0s\">https://www.youtube.com/watch?v=5BlLmJxNV0s</a></p>\n"
"<p><a href=\"https://www.youtube.com/watch?v=wtMoYjUIpDk\">https://www.youtube.com/watch?v=wtMoYjUIpDk</a></p>\n"
"<p><a href=\"https://www.youtube.com/watch?v=9U35vNlwj3o\">https://www.youtube.com/watch?v=9U35vNlwj3o</a></p>\n"
"<p><a href=\"https://www.youtube.com/watch?v=lFITZBBz_lk\">https://www.youtube.com/watch?v=lFITZBBz_lk</a></p>\n"
"<p><a href=\"https://www.youtube.com/watch?v=jjIp1qSkfgg\">https://www.youtube.com/watch?v=jjIp1qSkfgg</a></p>\n"
"<p><a href=\"https://www.youtube.com/watch?v=KM5g6wpY8a4\">https://www.youtube.com/watch?v=KM5g6wpY8a4</a></p>")
matches = re.finditer(regex, test_str, re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.