const regex = /(<a.*?(?:href=")?)?(https?:\/\/)?(?:www\.)?(?:youtu\.be\/|youtube\.com(?:\/embed\/|\/v\/|\/watch?.*?v=))([\w\-]{10,12})(.*<\/a>?)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<a.*?(?:href=")?)?(https?:\\\/\\\/)?(?:www\\.)?(?:youtu\\.be\\\/|youtube\\.com(?:\\\/embed\\\/|\\\/v\\\/|\\\/watch?.*?v=))([\\w\\-]{10,12})(.*<\\\/a>?)?', 'g')
const str = `<p> </p>
<p> </p>
https://www.youtube.com/watch?v=yCrjqNJgkNA
<p> </p>
<p> </p>
www.youtube.com/watch?v=TkRYM3Vt5v4
<p> </p>
<p> </p>
<p> </p>
http://www.youtube.com/watch?v=nfPYWD3Hxd4
<p><a href="https://www.youtube.com/watch?v=xV-ny2fNauA">https://www.youtube.com/watch?v=xV-ny2fNauA</a></p>
<p><a href="https://www.youtube.com/watch?v=4Quu-22CqHg">https://www.youtube.com/watch?v=4Quu-22CqHg</a></p>
<p><a href="https://www.youtube.com/watch?v=5BlLmJxNV0s">https://www.youtube.com/watch?v=5BlLmJxNV0s</a></p>
<p><a href="https://www.youtube.com/watch?v=wtMoYjUIpDk">https://www.youtube.com/watch?v=wtMoYjUIpDk</a></p>
<p><a href="https://www.youtube.com/watch?v=9U35vNlwj3o">https://www.youtube.com/watch?v=9U35vNlwj3o</a></p>
<p><a href="https://www.youtube.com/watch?v=lFITZBBz_lk">https://www.youtube.com/watch?v=lFITZBBz_lk</a></p>
<p><a href="https://www.youtube.com/watch?v=jjIp1qSkfgg">https://www.youtube.com/watch?v=jjIp1qSkfgg</a></p>
<p><a href="https://www.youtube.com/watch?v=KM5g6wpY8a4">https://www.youtube.com/watch?v=KM5g6wpY8a4</a></p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}