$re = '/(?:http[s]?:\/\/)?(?:www\.+)?([\-\w]+).*/m';
$str = 'http://google.com
http://google.co.jp
www.xakep.ru
https://youtube.com
https://www.youtube.com
www.hyphen-site.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);