const regex = /(?:http[s]?:\/\/)?(?:www\.+)?([\-\w]+).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:http[s]?:\\\/\\\/)?(?:www\\.+)?([\\-\\w]+).*', 'gm')
const str = `http://google.com
http://google.co.jp
www.xakep.ru
https://youtube.com
https://www.youtube.com
www.hyphen-site.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}