#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:http[s]?:\/\/)?(?:www\.+)?([\-\w]+).*"
Local $sString = "http://google.com" & @CRLF & _
"http://google.co.jp" & @CRLF & _
"www.xakep.ru" & @CRLF & _
"https://youtube.com" & @CRLF & _
"https://www.youtube.com" & @CRLF & _
"www.hyphen-site.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")