import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:http[s]?:\\/\\/)?(?:www\\.+)?([\\-\\w]+).*";
final String string = "http://google.com\n"
+ "http://google.co.jp\n"
+ "www.xakep.ru\n"
+ "https://youtube.com\n"
+ "https://www.youtube.com\n"
+ "www.hyphen-site.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}