const regex = /(25[0-5]|2[0-4]\d|1?\d\d?)(\.\g<-2>){3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(25[0-5]|2[0-4]\\d|1?\\d\\d?)(\\.\\g<-2>){3}', 'gm')
const str = `123 hahab abcde 123
//192.168.10.254/10.4.32.21 / 1.2.3 /125.258.33.22/ 432.2.3.475`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);