# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(25[0-5]|2[0-4]\d|1?\d\d?)(\.\g<-2>){3}//gm;t' <<< "123 hahab abcde 123
//192.168.10.254/10.4.32.21 / 1.2.3 /125.258.33.22/ 432.2.3.475"