// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^0\((\d{2})\)\s(\d{4,5})-(\d{4})$").unwrap();
let string = "0(11) 2222-3333
0(11) 22222-3333";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}