package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^0\((\d{2})\)\s(\d{4,5})-(\d{4})$`)
var str = `0(11) 2222-3333
0(11) 22222-3333`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}