$re = '/^0\((\d{2})\)\s(\d{4,5})-(\d{4})$/m';
$str = '0(11) 2222-3333
0(11) 22222-3333';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);