re = /^0\((\d{2})\)\s(\d{4,5})-(\d{4})$/m
str = '0(11) 2222-3333
0(11) 22222-3333'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end