import Foundation
let pattern = #"^(\d+)-(0[1-9]|1[012])-(0[1-9]|[12]\d|3[01])_([01]\d|2[0-3]):([0-5]\d):([0-5]\d|60)(\.\d+)?(([Zz])|([\+|\-]([01]\d+|2[0-3])))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2018-05-12_04:26:57.525+0000: [I] Accepted and connected to 9.4.127.199 ng.zc2.zurich <c0n9>
2018-05-28_09:01:01.825813-04:00 elastic-nfs-test systemd: Created slice User Slice of root.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)