// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d+)-(0[1-9]|1[012])-(0[1-9]|[12]\d|3[01])_([01]\d|2[0-3]):([0-5]\d):([0-5]\d|60)(\.\d+)?(([Zz])|([\+|\-]([01]\d+|2[0-3])))").unwrap();
let string = "2018-05-12_04:26:57.525+0000: [I] Accepted and connected to 9.4.127.199 ng.zc2.zurich <c0n9>
2018-05-28_09:01:01.825813-04:00 elastic-nfs-test systemd: Created slice User Slice of root.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}