package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+)-(0[1-9]|1[012])-(0[1-9]|[12]\d|3[01])_([01]\d|2[0-3]):([0-5]\d):([0-5]\d|60)(\.\d+)?(([Zz])|([\+|\-]([01]\d+|2[0-3])))`)
var str = `2018-05-12_04:26:57.525+0000: [I] Accepted and connected to 9.4.127.199 ng.zc2.zurich <c0n9>
2018-05-28_09:01:01.825813-04:00 elastic-nfs-test systemd: Created slice User Slice of root.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}